DigiTech Home

My Account

Help

Contact Support
FAQ FAQs

Message Board
   popular threads

 

 

 

Report A Problem

Report Abuse

 

 

 

 

login | create account

Legacy Products Thread :: HELP! Problems with my 2120 

(requires login)

Author

Message

Ben DeWitt

(unregistered)
 

Subject:

HELP! Problems with my 2120

08/12/2002


I recently purchased a used digitech 2120, and just put the upgrade chip in today. I was having some problems with it, and so i thought the upgrade would fix. BUT IT DID NOT. Basically, i let it warm up, cuz of the tubes, i thought that may have been the problem. what happens is it crackles like a radio sometimes (and uncontrollably, for variant amounts of time) when i switch to different channels on the control one... it seems to happen on channels with rever, wah, or delay on them. sometimes when i switch to channels like this, it just goes to a clean, almost bypass like sound....with no effects...even though is shows that it is working....I feel like i got ripped off, but i cant do anything about that, so now i want to see if i can get it fixed. I would appreciate it if you would let me know what i can do.

Ben DeWitt

ben dewitt

(unregistered)
 

Subject:

Re: HELP! Problems with my 2120

08/13/2002


by the way, i also did what someone else has already said...about the static....i turn my amp on first always...as it needs warming.


coco

(unregistered)
 

Subject:

Re: HELP! Problems with my 2120

08/13/2002


definitely call Digitech support (the ph#'s here on this site somewhere, sorry I don't have it handy),

they are great; it is worth it to send to them for repair.

Mark Bratcher

(unregistered)
 

Subject:

Re: HELP! Problems with my 2120

08/13/2002


As a last ditch effort, I'd change out the 12AX7WA's if you have any spare ones (eg, from your amp?).

Outside of that, I agree with coco. Go to the support web page on this here DigiTech website and fill in the form and hit "send". Give a clear description of the problem including whether it's intermittent or whether always occurs under certain conditions. They're great at responding. Even if you have to send it it, it won't cost you an arm and a leg.

ben dewitt

(unregistered)
 

Subject:

Re: HELP! Problems with my 2120

08/15/2002


ok...i sent it in to digitech. and its not the tubes, but i'm thinking of switching out the tubes to something different anyway....
ben

tom kielemoes

(unregistered)
 

Subject:

Re: HELP! Problems with my 2120

09/03/2002


hey ben,

i've the same problem man and no one seems be able to fix it, haven't send it in at digitech, cause i need it a lot to play, i don't have to change during a song or so so i can use it for now, is it also that when you have changed an effect and the crackle sounds, turn him off and then on and then you can play with this effect, they also told me from the support to change the tubes, but that isn't it, I just heard from another guy who has just bought one that he has the same f***in problem, this is not right, i don't knwo where you from but we are from belgium, europe. Could it be that the bad ones where sent to europe ???? If you have it back could you send me a message what it was and how much the cost is, if not in guarantuee, mine isn't anymore. could it be a Y2K bug ??? in the program.....

(requires login)

Vote on this thread:

Mark this as a "Sticky" thread.
Don't mark this as a sticky thread.

(requires login)

 

© 2014 DigiTech®. All Rights Reserved.